#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s"
Local $sString = "feat(VLOT-1355): такое вот описание" & @CRLF & _
"feat(VLOT-1355,VLOT-1440): вот такое вот описание" & @CRLF & _
"feat: вот такое вот описание" & @CRLF & _
"bugfix(VLOT-1355): вот такая бага" & @CRLF & _
"bugfix: вот еще бага" & @CRLF & _
"bugfix или так" & @CRLF & _
"feat чето там"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")