import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:feat|bugfix)(:?\\((?:VLOT-\\d+\\,?)+\\))?:\\s";
final String string = "feat(VLOT-1355): такое вот описание\n"
+ "feat(VLOT-1355,VLOT-1440): вот такое вот описание\n"
+ "feat: вот такое вот описание\n"
+ "bugfix(VLOT-1355): вот такая бага\n"
+ "bugfix: вот еще бага\n"
+ "bugfix или так\n"
+ "feat чето там";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}