const regex = /(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:feat|bugfix)(:?\\((?:VLOT-\\d+\\,?)+\\))?:\\s', 'gm')
const str = `feat(VLOT-1355): такое вот описание
feat(VLOT-1355,VLOT-1440): вот такое вот описание
feat: вот такое вот описание
bugfix(VLOT-1355): вот такая бага
bugfix: вот еще бага
bugfix или так
feat чето там`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}