$re = '/(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s/m';
$str = 'feat(VLOT-1355): такое вот описание
feat(VLOT-1355,VLOT-1440): вот такое вот описание
feat: вот такое вот описание
bugfix(VLOT-1355): вот такая бага
bugfix: вот еще бага
bugfix или так
feat чето там';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);