using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s";
string input = @"feat(VLOT-1355): такое вот описание
feat(VLOT-1355,VLOT-1440): вот такое вот описание
feat: вот такое вот описание
bugfix(VLOT-1355): вот такая бага
bugfix: вот еще бага
bugfix или так
feat чето там";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}