import Foundation
let pattern = #""([^"]+("[^"]+")?)"?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"«$1»"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)