package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)"([^"]+("[^"]+")?)"?$`)
var str = `ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий""`
var substitution = "«$1»"
fmt.Println(re.ReplaceAllString(str, substitution))
}