# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([^"]+("[^"]+")?)"?$/«$1»/gmi;t' <<< "ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий\"
ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"
ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"\""