// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)"([^"]+("[^"]+")?)"?$"#).unwrap();
let string = "ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий\"
ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"
ООО \"Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ \"КраÑноÑÑ€Ñкий рабочий\"\"";
let substitution = "«$1»";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}