use strict;
my $str = 'ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий""';
my $regex = qr/"([^"]+("[^"]+")?)"?$/mip;
my $subst = '«$1»';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";