#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)"([^"]+("[^"]+")?)"?$"
Local $sString = "ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий"" & @CRLF & _
"ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"" & @CRLF & _
"ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"""
Local $sSubst = "«$1»"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)