$re = '/"([^"]+("[^"]+")?)"?$/mi';
$str = 'ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий"
ООО "Ð ÐµÐ´Ð°ÐºÑ†Ð¸Ñ Ð³Ð°Ð·ÐµÑ‚Ñ‹ "КраÑноÑÑ€Ñкий рабочий""';
$subst = "«$1»";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;