// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:").unwrap();
let string = "-- Standard (and with preceding space)
//TODO: Test
//TODO: Test
-- Space after //
// TODO: Test
// TODO: Test
-- Space befre :
//TODO : Test
//TODO : Test
-- Space after // AND befre :
// TODO : Test
// TODO : Test
// TODO : Test
^: \"\\/\\/\\s*TODO\\s*:\"(\\s* is \"zero or more of a space)
-- Misspellong TOOD
//TOOD: Test
// TOOD: Test
//TOOD : Test
//TOODO: Test
//TOODO : Test
//TODDO : Test
// TODDO : Test
-- Misspellong TDOO
//TDOO: Test
// TDOO: Test
// TDOO : Test
^^ [All above]: \"\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:\" (with different misspelling options)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}