package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:`)
var str = `-- Standard (and with preceding space)
//TODO: Test
//TODO: Test
-- Space after //
// TODO: Test
// TODO: Test
-- Space befre :
//TODO : Test
//TODO : Test
-- Space after // AND befre :
// TODO : Test
// TODO : Test
// TODO : Test
^: "\/\/\s*TODO\s*:"(\s* is "zero or more of a space)
-- Misspellong TOOD
//TOOD: Test
// TOOD: Test
//TOOD : Test
//TOODO: Test
//TOODO : Test
//TODDO : Test
// TODDO : Test
-- Misspellong TDOO
//TDOO: Test
// TDOO: Test
// TDOO : Test
^^ [All above]: "\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:" (with different misspelling options)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}