#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:"
Local $sString = "-- Standard (and with preceding space)" & @CRLF & _
"//TODO: Test" & @CRLF & _
" //TODO: Test" & @CRLF & _
"" & @CRLF & _
"-- Space after //" & @CRLF & _
"// TODO: Test" & @CRLF & _
"// TODO: Test" & @CRLF & _
"" & @CRLF & _
"-- Space befre :" & @CRLF & _
"//TODO : Test" & @CRLF & _
"//TODO : Test" & @CRLF & _
"" & @CRLF & _
"-- Space after // AND befre :" & @CRLF & _
"// TODO : Test" & @CRLF & _
"// TODO : Test" & @CRLF & _
"// TODO : Test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^: "\/\/\s*TODO\s*:"(\s* is "zero or more of a space)" & @CRLF & _
"" & @CRLF & _
"-- Misspellong TOOD" & @CRLF & _
"//TOOD: Test" & @CRLF & _
"// TOOD: Test" & @CRLF & _
"//TOOD : Test" & @CRLF & _
"//TOODO: Test" & @CRLF & _
"//TOODO : Test" & @CRLF & _
"//TODDO : Test" & @CRLF & _
"// TODDO : Test" & @CRLF & _
"" & @CRLF & _
"-- Misspellong TDOO" & @CRLF & _
"//TDOO: Test" & @CRLF & _
"// TDOO: Test" & @CRLF & _
"// TDOO : Test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^^ [All above]: "\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:" (with different misspelling options)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")