const regex = /\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:', 'gm')
const str = `-- Standard (and with preceding space)
//TODO: Test
//TODO: Test
-- Space after //
// TODO: Test
// TODO: Test
-- Space befre :
//TODO : Test
//TODO : Test
-- Space after // AND befre :
// TODO : Test
// TODO : Test
// TODO : Test
^: "\\/\\/\\s*TODO\\s*:"(\\s* is "zero or more of a space)
-- Misspellong TOOD
//TOOD: Test
// TOOD: Test
//TOOD : Test
//TOODO: Test
//TOODO : Test
//TODDO : Test
// TODDO : Test
-- Misspellong TDOO
//TDOO: Test
// TDOO: Test
// TDOO : Test
^^ [All above]: "\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:" (with different misspelling options)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}