re = /\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:/m
str = '-- Standard (and with preceding space)
//TODO: Test
//TODO: Test
-- Space after //
// TODO: Test
// TODO: Test
-- Space befre :
//TODO : Test
//TODO : Test
-- Space after // AND befre :
// TODO : Test
// TODO : Test
// TODO : Test
^: "\\/\\/\\s*TODO\\s*:"(\\s* is "zero or more of a space)
-- Misspellong TOOD
//TOOD: Test
// TOOD: Test
//TOOD : Test
//TOODO: Test
//TOODO : Test
//TODDO : Test
// TODDO : Test
-- Misspellong TDOO
//TDOO: Test
// TDOO: Test
// TDOO : Test
^^ [All above]: "\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:" (with different misspelling options)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end