import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:";
final String string = "-- Standard (and with preceding space)\n"
+ "//TODO: Test\n"
+ " //TODO: Test\n\n"
+ "-- Space after //\n"
+ "// TODO: Test\n"
+ "// TODO: Test\n\n"
+ "-- Space befre :\n"
+ "//TODO : Test\n"
+ "//TODO : Test\n\n"
+ "-- Space after // AND befre :\n"
+ "// TODO : Test\n"
+ "// TODO : Test\n"
+ "// TODO : Test\n\n\n"
+ "^: \"\\/\\/\\s*TODO\\s*:\"(\\s* is \"zero or more of a space)\n\n"
+ "-- Misspellong TOOD\n"
+ "//TOOD: Test\n"
+ "// TOOD: Test\n"
+ "//TOOD : Test\n"
+ "//TOODO: Test\n"
+ "//TOODO : Test\n"
+ "//TODDO : Test\n"
+ "// TODDO : Test\n\n"
+ "-- Misspellong TDOO\n"
+ "//TDOO: Test\n"
+ "// TDOO: Test\n"
+ "// TDOO : Test\n\n\n"
+ "^^ [All above]: \"\\/\\/\\s*(TODO|TDOO|TOOD|TOODO|TODDO)\\s*:\" (with different misspelling options)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}