using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:";
string input = @"-- Standard (and with preceding space)
//TODO: Test
//TODO: Test
-- Space after //
// TODO: Test
// TODO: Test
-- Space befre :
//TODO : Test
//TODO : Test
-- Space after // AND befre :
// TODO : Test
// TODO : Test
// TODO : Test
^: ""\/\/\s*TODO\s*:""(\s* is ""zero or more of a space)
-- Misspellong TOOD
//TOOD: Test
// TOOD: Test
//TOOD : Test
//TOODO: Test
//TOODO : Test
//TODDO : Test
// TODDO : Test
-- Misspellong TDOO
//TDOO: Test
// TDOO: Test
// TDOO : Test
^^ [All above]: ""\/\/\s*(TODO|TDOO|TOOD|TOODO|TODDO)\s*:"" (with different misspelling options)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}