re = /[\"\'\\]/
str = '"hello"
\'); WHERE 1=1 --
\\"'
subst = '\\\\\\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result