import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\"\\'\\\\]";
final String string = "\"hello\"\n"
+ "'); WHERE 1=1 --\n"
+ "\\\"";
final String subst = "\\\\\\0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}