const regex = /[\"\'\\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\"\\\'\\\\]', 'g')
const str = `"hello"
'); WHERE 1=1 --
\\"`;
const subst = `\\\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);