$re = '/[\"\'\\\\]/';
$str = '"hello"
\'); WHERE 1=1 --
\\"';
$subst = "\\\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;