use strict;
my $str = '"hello"
\'); WHERE 1=1 --
\\"';
my $regex = qr/[\"\'\\]/p;
my $subst = '\\\\\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";