import Foundation
let pattern = #"^(\d{4})-(\d{2})-(\d{2})(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1/\2/\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)