# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{4})-(\d{2})-(\d{2})(.*)"
test_str = "2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49"
subst = "\\1/\\2/\\3\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.