#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{4})-(\d{2})-(\d{2})(.*)"
Local $sString = "2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49"
Local $sSubst = "\1/\2/\3\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)