const regex = /^(\d{4})-(\d{2})-(\d{2})(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})-(\\d{2})-(\\d{2})(.*)', 'gm')
const str = `2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49`;
const subst = `\1/\2/\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);