use strict;
my $str = '2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49';
my $regex = qr/^(\d{4})-(\d{2})-(\d{2})(.*)/mp;
my $subst = '\\1/\\2/\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";