$re = '/^(\d{4})-(\d{2})-(\d{2})(.*)/m';
$str = '2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49';
$subst = "\1/\2/\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;