import Foundation
let pattern = #"\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
App\Entity\Product-fetchAll GET ANY ANY /api/products
App\Entity\Product-fetchOne GET ANY ANY /api/product/{id}
App\Entity\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}
App\Entity\Product-createOne POST ANY ANY /api/product
App\Entity\Product-deleteOne DELETE ANY ANY /api/product/{id}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)