// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)").unwrap();
let string = " App\\Entity\\Product-fetchAll GET ANY ANY /api/products
App\\Entity\\Product-fetchOne GET ANY ANY /api/product/{id}
App\\Entity\\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}
App\\Entity\\Product-createOne POST ANY ANY /api/product
App\\Entity\\Product-deleteOne DELETE ANY ANY /api/product/{id}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}