const regex = /\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?P<entity>([-\\w]*\\\\){2}([-\\w]*))(?:\\s*)(?P<METHOD>([A-Z]*\\|?)*)\\s*(?P<SCHEME>(?4))\\s*(?P<HOST>(?4))\\s*(?P<PATH>.*)', 'gm')
const str = ` App\\Entity\\Product-fetchAll GET ANY ANY /api/products
App\\Entity\\Product-fetchOne GET ANY ANY /api/product/{id}
App\\Entity\\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}
App\\Entity\\Product-createOne POST ANY ANY /api/product
App\\Entity\\Product-deleteOne DELETE ANY ANY /api/product/{id}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}