#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)"
Local $sString = " App\Entity\Product-fetchAll GET ANY ANY /api/products" & @CRLF & _
" App\Entity\Product-fetchOne GET ANY ANY /api/product/{id}" & @CRLF & _
" App\Entity\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}" & @CRLF & _
" App\Entity\Product-createOne POST ANY ANY /api/product" & @CRLF & _
" App\Entity\Product-deleteOne DELETE ANY ANY /api/product/{id}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")