using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)";
string input = @" App\Entity\Product-fetchAll GET ANY ANY /api/products
App\Entity\Product-fetchOne GET ANY ANY /api/product/{id}
App\Entity\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}
App\Entity\Product-createOne POST ANY ANY /api/product
App\Entity\Product-deleteOne DELETE ANY ANY /api/product/{id}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}