import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?P<entity>([-\\w]*\\\\){2}([-\\w]*))(?:\\s*)(?P<METHOD>([A-Z]*\\|?)*)\\s*(?P<SCHEME>(?4))\\s*(?P<HOST>(?4))\\s*(?P<PATH>.*)";
final String string = " App\\Entity\\Product-fetchAll GET ANY ANY /api/products\n"
+ " App\\Entity\\Product-fetchOne GET ANY ANY /api/product/{id}\n"
+ " App\\Entity\\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}\n"
+ " App\\Entity\\Product-createOne POST ANY ANY /api/product\n"
+ " App\\Entity\\Product-deleteOne DELETE ANY ANY /api/product/{id}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}