use strict;
my $str = ' App\\Entity\\Product-fetchAll GET ANY ANY /api/products
App\\Entity\\Product-fetchOne GET ANY ANY /api/product/{id}
App\\Entity\\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}
App\\Entity\\Product-createOne POST ANY ANY /api/product
App\\Entity\\Product-deleteOne DELETE ANY ANY /api/product/{id}';
my $regex = qr/\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}