import Foundation
let pattern = #"\D+([0-9]/[0-9]|.)\s+(\d+\.\d+\.\d+\.\d+|unngiged)\s+(YES|NO)\s+\D{4,}\s+[A-Za-z]{2,}\s+[A-Za-z]{2,}\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ethernet0/0 192.168.2.129 YES DHCP up up
Ethernet0/0 192.168.2.129 YES unngiged up up
Ethernet0/0 unngiged YES unngiged up up
loopback1 unngiged YES unngiged up up
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)