use strict;
my $str = 'Ethernet0/0 192.168.2.129 YES DHCP up up
Ethernet0/0 192.168.2.129 YES unngiged up up
Ethernet0/0 unngiged YES unngiged up up
loopback1 unngiged YES unngiged up up ';
my $regex = qr/\D+([0-9]/[0-9]|.)\s+(\d+\.\d+\.\d+\.\d+|unngiged)\s+(YES|NO)\s+\D{4,}\s+[A-Za-z]{2,}\s+[A-Za-z]{2,}\s+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}