// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\D+([0-9]/[0-9]|.)\s+(\d+\.\d+\.\d+\.\d+|unngiged)\s+(YES|NO)\s+\D{4,}\s+[A-Za-z]{2,}\s+[A-Za-z]{2,}\s+").unwrap();
let string = "Ethernet0/0 192.168.2.129 YES DHCP up up
Ethernet0/0 192.168.2.129 YES unngiged up up
Ethernet0/0 unngiged YES unngiged up up
loopback1 unngiged YES unngiged up up ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}