import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D+([0-9]/[0-9]|.)\\s+(\\d+\\.\\d+\\.\\d+\\.\\d+|unngiged)\\s+(YES|NO)\\s+\\D{4,}\\s+[A-Za-z]{2,}\\s+[A-Za-z]{2,}\\s+";
final String string = "Ethernet0/0 192.168.2.129 YES DHCP up up \n"
+ "Ethernet0/0 192.168.2.129 YES unngiged up up \n"
+ "Ethernet0/0 unngiged YES unngiged up up \n"
+ "loopback1 unngiged YES unngiged up up ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}