const regex = new RegExp('\\D+([0-9]/[0-9]|.)\\s+(\\d+\\.\\d+\\.\\d+\\.\\d+|unngiged)\\s+(YES|NO)\\s+\\D{4,}\\s+[A-Za-z]{2,}\\s+[A-Za-z]{2,}\\s+', 'gm')
const str = `Ethernet0/0 192.168.2.129 YES DHCP up up
Ethernet0/0 192.168.2.129 YES unngiged up up
Ethernet0/0 unngiged YES unngiged up up
loopback1 unngiged YES unngiged up up `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}