using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D+([0-9]/[0-9]|.)\s+(\d+\.\d+\.\d+\.\d+|unngiged)\s+(YES|NO)\s+\D{4,}\s+[A-Za-z]{2,}\s+[A-Za-z]{2,}\s+";
string input = @"Ethernet0/0 192.168.2.129 YES DHCP up up
Ethernet0/0 192.168.2.129 YES unngiged up up
Ethernet0/0 unngiged YES unngiged up up
loopback1 unngiged YES unngiged up up ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}