# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\D+([0-9]/[0-9]|.)\s+(\d+\.\d+\.\d+\.\d+|unngiged)\s+(YES|NO)\s+\D{4,}\s+[A-Za-z]{2,}\s+[A-Za-z]{2,}\s+"
test_str = ("Ethernet0/0 192.168.2.129 YES DHCP up up \n"
"Ethernet0/0 192.168.2.129 YES unngiged up up \n"
"Ethernet0/0 unngiged YES unngiged up up \n"
"loopback1 unngiged YES unngiged up up ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.