import Foundation
let pattern = #"^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\?"?([^"]*)\\?"?"$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] "GET /wp/feed/ HTTP/1.1" 200 11736 "-" "Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}