package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\?"?([^"]*)\\?"?"$`)
var str = `212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] "GET /wp/feed/ HTTP/1.1" 200 11736 "-" "Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)"
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}