using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S*).*\[(.*)\]\s""(\S*)\s(\S*)\s([^""]*)""\s(\S*)\s(\S*)\s""([^""]*)""\s""\\?""?([^""]*)\\?""?""$";
string input = @"212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] ""GET /wp/feed/ HTTP/1.1"" 200 11736 ""-"" ""Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)""
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}