// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\?"?([^"]*)\\?"?"$"#).unwrap();
let string = "212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] \"GET /wp/feed/ HTTP/1.1\" 200 11736 \"-\" \"Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)\"
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}