use strict;
my $str = '212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] "GET /wp/feed/ HTTP/1.1" 200 11736 "-" "Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)"
';
my $regex = qr/^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\?"?([^"]*)\\?"?"$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}