$re = '/^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\\\?"?([^"]*)\\\\?"?"$/';
$str = '212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] "GET /wp/feed/ HTTP/1.1" 200 11736 "-" "Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)"
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);